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Using Acropolis to create a Web Folder
This topic is optional and will probably not be covered
in class. The easiest way to create a Web folder on
the Homepage server so you can publish pages to the
internet is to login to Acropolis. So open a Web browser
and go to the following URL: http://asw.iastate.edu/
Next enter your ISU NetID and password then click on
the LOGIN button.
To created a Web (WWW) folder and a default web
page (homepage.html) for your ISU Netid:
1. Click on Manage NetID
2. Click on View/Edit your personal Web Page
Settings.
3. Click on Register Web Page then click on the
Register button.
4. Click on the Homepage link near the top which
is within the ASW > User > Homepage > Register
bookmarks.
5. Click on Create Default Web Page.
6. Since thats all we need to do, click the Logout
button to get out of Acropolis. You can then upload
and download files to your WWW folder by using
ISU Webfile: http://webfile.iastate.edu/
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General Flash Information
Adobe Flash is a software authoring tool for
creating scalable, interactive animated graphics and navigation controls for the Web. Flash
is also one of the most popular add-on tools
for internet browsers and is currently available
on most browsers throughout the Web. Flash
is known for creating Web graphics that are
small in size but dynamic in sound, motion and
graphics.


Starting Flash
To begin Flash on a Macintosh, look on the Macintosh
lower toolbar inside the Applications folder and doubleclick on the Flash application. On a Windows system
to startup Flash, click under the Start icon then select
All Programs, Adobe Design, then Adobe Flash.
From the Flash starting screen— press Flash File (Actionscript 2.0) under Create New; this will start a
Flash project for you and allow you to see the distinct
areas within Flash. For the Flash layout for today’s
class, pull down in the upper right to Designer then
pull the Properties panel under the main Stage and
pull the dividing line on the left to be two columns
wide. Next pull down under the layouts on the upper
right and select New Workspace then save this setting
as Classicplus.
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Flash Layout
There are five distinct areas within Flash: the
Drawing Toolbar, Menubar, Timeline, the
Stage/Work Area, and the Floating Panels
which includes the special Properties Panel.

You work in the Stage area using tools from the Toolbar. You must select the image frame on which you are
working from the Timeline and the Floating Panels give
you information on the currently selected Stage item
and allow you to alter that item.
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Drawing Toolbar Area
Toolbar Tools
The Drawing Toolbar has four distinct sections
which include the tools area and the view,
color and options areas. The Tools area has
all the drawing tools that you can use on the
Stage:

More of these tools are very similar to the ones used in
Photoshop and are self-explanatory. The White Arrow
or Subselection tool is a unique tool for Flash that allows
you to view and modify anchor points. Any tool with
a lower right arrow means that the tool in question has
additional related tools underneath. For instance, if you
pull down under the Free Transform tool then you will
find the Gradient Tool.
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Drawing Toolbar Sections
The three lower sections on the drawing Toolbar are the View, Colors and Options areas.
The View area includes the Hand tool to move
around the stage and the Zoom tool to zoom
in or out on your work. The Colors area allows
you to choose line/pencil and brush/bucket/text
colors as well as defaulting, swapping or turning off colors. The Options area changes to
show the options on the currently selected tool.

Try clicking then selecting a different stroke and fill color
in order to examine the full color grid. You can also
select the spectrum ball in the upper right corner of
the color grid for even more color options or select the
Alpha level of your color also in the upper right. Click
the Default button when you are done to return to the
standard color set.
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Menubar and Stage Areas
The Menubar area is typical of most software
programs. Of particular interest in Flash under the Control menubar option is the ability to Test a particular Flash movie or scene
to see how it looks. Also under the Modify
menubar option is the ability to modify your
Document/Movie to have a particular frame
rate, size or background color. Just like in a
film, you can have multiple scenes in one movie
and the frame rate determines the speed.
If you move around the sliders in the stage
area, there is a point where the background
goes to gray. This distinguishes the On-Stage
area that people can see from the Off-Stage
area where you might have items waiting to
move or spin onto the Stage. Remember that
Off-Stage items are not seen in the final movie
until they move onto the Stage.
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Timeline Area
The Timeline area shows you what is happening at a particular time on the Stage.

The Frames section shows how many frames
are in your Flash presentation and extends to
the right. The Playhead within the Frames
shows which Frame is currently showing on the
Stage. Each Frame can have multiple Layers with each Layer containing the actual content of the Flash Movie. Movie elements that
shouldn’t be grouped together need to be on
separate Layers. Like, for instance, you would
probably create a separate Layer for your Flash
Sounds or Buttons. You can even have Layer
folders which are groups of Layers.
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Floating Panels Area
The Panels area contains information or options for the currently selected stage item or
tool. Panels float so that you can move them
anywhere you want on your screen. The Panels that are most often used are Properties
(object/tool information), Color (color mixer),
Behaviors (Simple Scripts) and Components
(specialized tools).
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Project- Shape Tweening Blobs
The first project we are going to work on is a
traditional Flash first project named tweening
blobs. Pull down under File → Save as and
name your project blobs.fla then save it to
your desktop.


Inserting the Blobs
First make sure the Timeline Playhead is on
frame one and click into Frame 1, Layer1
with the pointer tool. After that choose the
Brush icon from the Toolbar, then select an
interesting brush size/color in the Options/Fills
areas and make a blob somewhere on the upper
left portion of the stage.
Press F5 four times to make four new frames on the
Timeline. Next select frame 5 and pull down under Insert to Timeline then over to Blank Keyframe. Make
another blob with your brush just a little to the right
and down from your previous blob.
Create five new frames with F5 then select frame
10 and pull down under Insert once again to Blank
Keyframe. Continue to do this until you reach Frame
25 and remember to put a new blob in at Frame 25.
You can always Edit then Undo if you make a mistake.
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Tweening the Blobs
Select Frame 1 again with the Playhead by
clicking in the Layer 1/Frame 1 box. Next
pull down under Insert → Shape tween. You
should see a green background and an arrow
pointing to frame 5 in frames 2, 3 and 4. Flash
is doing a shape tween within those frames. Do
this for all your keyframes.
Pull down under File then Save your project. Next
run your movie by pulling down under Control to Test
Movie or by scrubbing the Timeline with the Playhead.
You should see your blob move from the upper left to
the lower right over and over again. If this is happening
too fast, pull down under Modify → Document and
set the frame rate down to 12.
Keyframing and Tweening A Keyframe is a frame in
a particular Layer where you want to alter the action of
that Layer’s items/objects. It works as a guidepost for
Flash telling it where to be and what it needs to look
like by that particular frame.
Tweening is the act of filling in between Keyframes.
Flash can do this on its own or you can do it by creating all keyframes. There are two standard types of
tweening: Motion and Shape. Shape produces a morphing type of effect.
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Adding a Second Layer
Now to create a second blob to go with our
first blob, we’ll want to put in a second layer
so they can be tweened separately and have
separate paths.
Pull down under Insert to Timeline then over
to Layer. Click on Layer 2/Frame 1, click on
the brush tool and select a new brush color.
Now do the same thing we did on the first layer
creating and tweening 25 frames starting in the
upper left and going to the lower right but this
time you won’t have to press F5 because your
new Layer will start with 25 frames. Create
at least one point where the two blobs overlap
and end the two blobs across from one another.
Test your movie and look at your results.
Overlapping Layers
On Layers that overlap items, the topmost Layer will be
seen. Drag your Playhead to the point in your Movie
where your blobs overlap. Now click in the area where
it says ‘Layer 2’ and drag it down below Layer 1. Layer
1 should now be seen over Layer 2.
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Getting Back to Start- Optional
A lot of times in animation you want to end
up back where you started. This is sometimes
called the ‘Ping-Pong’ effect. Let’s Pong our
blobs back to their starting positions.
Select Frame 25 of Layer 1. Add five new frames with
F5. On the 30th frame, select Insert then Blank
Keyframe. Select the box in frame 20 on Layer 1.
Select Edit then Copy. Go to Frame 30 and pull down
under Edit to Paste in Place. Add five new frames and
then do this again for frames 15, 10, 5 and 1. When
you get to frame 50 put in 10 additional frames and a
keyframe at 60. Test your Movie and then do the same
thing for your other Layer.
You can also simply put in 25 new frames, put a new
Blank keyframe in frame 50 and copy and paste in the
frame from frame 1. Then just add 10 additional frames
and a keyframe at frame 60. This doesn’t look as good
but is a lot faster.
Invisible Layers
If you’re getting confused on the Stage, try hiding one
or more of your Layers temporarily by clicking under the
Eyeball icon next to the layer name. This will hide that
Layer on the Stage. Click it again to reveal the Layer.
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Adding a Name
Pull down under Insert then down to Timeline and over to Layer to add a new layer to
this project. The name “Layer 3” isn’t too descriptive here so let’s change that by doubleclicking on the Layer 3 name then typing in
Text and pressing Return. Now this layer has
a more descriptive name.
Select Frame 25 of the Text layer and insert a Keyframe. Click the Text Tool on
the Toolbar and change the color to black.
Then choose an appropriate size font from the
Properties Panel and type the following center stage between the blobs: From the Desk
of Your Name.
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You may also want to click the Bold option
in the Properties Panel or Center your text.
You can use the Arrow Tool to move around
your text once you are finished typing. Move
the Text Layer so it is the bottom layer and
Test your movie. On the Text Layer move
to where the blobs have obscured part of the
name and create a blank keyframe. Now it
sort of looks like that your nameplate disappears into thin air.
At this point, select Modify on the menubar and pull
down to Document. Choose an appropriate background
color for your Movie and alter the Movie’s height and
width so that it can just barely play within the Movie’s
confines.


Publishing and Uploading
Save your Movie by pulling down under File on the
menubar to Save. To Publish your Flash Movie for
use on the Web, pull down under File to Publish Settings. By default, you will create a Flash file (.swf) and
an HTML file (.html) when you publish. You will need
to upload both of these files and use the .html file to
view the .swf file.
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Click the Flash folder tab and click the Protect from import checkbox. This will protect
your Flash file from being borrowed by other
people on the Web. There is also a JPEG
quality setting there that you can set. Click
the Publish button and Flash will create your
.swf and .html files then click OK. Go to your
desktop and Double-click the blobs.html file to
view your creation.
You can upload your two files: blobs.swf and
blobs.html to the Iowa State Homepage server
by using ISU webfile which is available at:
http://webfile.iastate.edu/. Simply upload these
two files to your WWW folder.
Once you’ve uploaded, you can view your work
at: http://netid.public.iastate.edu/blobs.html
where netid is your ISU NetId and blobs is the
name of your Flash project.
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Project- A Mini-Bulletin Board


Putting a Button in Motion
Pull down under File to New, choose Flash File, Actionscript 2.0 then click OK. Pull down under File
to Save then save your file to the desktop and name it
bb.fla. Next pull down under Window to Common Libraries and finally to Buttons. The Common Libraries
contain media materials that come with Flash. Click
and drag any classic Button from the Library onto the
upper left corner of the Stage.
Insert fourteen frames with F5 then create a Keyframe
at Frame 15 (Insert → Timeline → Keyframe) and
move the button with the Arrow Tool to Stage right.
Click the Layer 1/Frame 1 box, pull down under Insert
to Classic Tween. The Classic Tween is a classic motion tween. You should see a blue-backed arrow area
between frames 1 and 15 which shows that Flash is
tweening. Save your project then test your movie. The
button should glide across the stage.
Return to frame 15. Create fifteen more frames by
pressing F5 then make a keyframe at frame 30 and
move the button to the lower right corner. After you
put in a few frames, you can also ctrl-click and drag the
tag at the end of a layer to create new frames.
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Next make fifteen more frames then create a keyframe
at frame 45 and move the button to the lower left corner. Finally create 15 more frames with F5 then create
a blank keyframe at Frame 60 and copy frame 1 to
frame 60. Put in a classic motion tween at frames 15,
30 and 45 then save and test your movie.


Creating a New Style Motion Tween
CS4 introduced a new way to motion tween that is easier to use and doesn’t use as much traditional keyframing. It is intended to be used more for casual animation
where a whole layer is devoted to the animation itself.
Let’s try it out.
Hide the current layer and create a new layer by pulling
down under Insert → Timeline → Layer. Next grab
another classic button and put it into the upper right
hand corner, name the button btn1 in the Properties
area then pull down under Insert → Motion Tween.
Now the whole layer is tween ready.
Next simply click on frame 15 and pull the button to
the upper left corner. Next go to frame 30 and pull the
button to the lower left corner. After that, go to frame
45 and pull the button to the lower right corner and
finally go to frame 60 and put the button back where
you started. You should see small black diamonds on
frames 15, 30, 45 and 60 called auto-keyframes where
Flash is using the new style of keyframing for you. This
style of motion tweening is a lot faster to setup but it
does take away a certain amount of layer flexibility.
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Creating a Message Symbol
Test out your movie and you may want to change the
frame rate down to 12 or 18 by going under Modify
→ Document. Next up, let’s create a message symbol
that we can alter independently to create a message.
So create a New Layer in your project and name it Text.
We are going to create a flying message that spins in by
frame 30 to the middle of the stage. To spin the message, we’ll have to create a symbol with our message
inside of it.
Pull down under Insert to New Symbol and create a
new symbol named msg. Choose a Graphic Type: for
the symbol, name your symbol msg then click OK.
When you are finished, you are put into the message
symbol itself so you can create it. Use the Text Tool
from the Toolbar Panel and put your message in the
Center of the Stage. You can use the Arrow Tool to
help center the name on the crosshairs or use the Align
tool by pulling down under Window to Align. Remember to align items to the Stage. When you are done,
click back to Scene 1 at the top left of the stage below
the timeline.
Symbols
Symbols are objects within Flash that Flash can manipulate. Symbols can be Buttons, Graphics or even Movie
clips. You generally use symbols when you want to use
a graphic more than once or when you want to flip or
rotate a text item. A Movie clip symbol can contain an
entire movie within itself.
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Message Spinning
Move to the Text Layer/Frame 1 box on the
Timeline and move the Stage sliders so that
you are off the top portion of the Stage. Pull
down under Window to Library and click and
drag your Message symbol to the grey area
just above the stage. The Library is your media library for the current project. You should
also see your classic Button there.
Create a keyframe at Frame 30 and move your Message
so that it sits in the center of the stage. Click to Frame
1 and insert a Classic Tween then go to the Properties
Panel and alter the tween to have 4 Clockwise (CW)
rotations. Save and Test your movie.
Create a keyframe at frame 45 and 60 of the Text Layer.
At frame 45 do a Classic tween then go to frame 60 and
click on your stage Message. Next go to the Properties Panel and under Color Effects choose the Alpha
Setting then set the level to 0. This will cause your
message to fade away. Save and Test your movie.
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Go to frame 60 on the Text layer then select the msg
symbol on stage again. Pull down under Modify to
Transform then over to Scale. Pull in on the square
anchor point on a corner of your msg symbol and make
it smaller. Save and test your movie and you will find
that the message now gets smaller as it fades away. See
if you can get it to rotate, get smaller and fade at the
same time.
Instances- Optional
A symbol can have more than one occurrence. Each
occurrence of a symbol is called an Instance. Go to
Layer 1/Frame 1 and with the Pointer tool click on the
Button instance on the Stage. Pull down under Edit
to Duplicate. Now with very little extra space, you’ve
added a second button to your Flash movie. Edit, cut
and paste your new button to a new Layer and place it
to start on the bottom right corner of the stage.
Click on your new button. Name this instance by typing
in btn2 in the <Instance Name> box of the Properties
panel. Next go to the Color Effect area, change the
Style to Tint and alter the tint colors. Now add a new
style Motion Tween to this layer and move the btn2
around in a square adding auto-keyframes at 15, 30,
45 and ending up back where it started at 60. After
all that, Save and Test your movie. You should now
have three buttons of different colors that cross over
one another. If you feel this is out of balance, you can
add a fourth button in the lower right as well.
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Adding Sounds- Optional
Go http://css.ait.iastate.edu/Flash/, left-click or ctrlclick on the Flash 1 class data links and download banjo2.aif
and lock.aif to your desktop. Pull down under File to
Import then over to Import to Library then select both
of the sounds and click on Import to Library. Create
a New Layer and name it Sounds then click to frame 15
and create a Keyframe. Select the lock.aif from your
Library then click and drag it onto the stage. Save and
test your movie. This is known as an event sound.
Let’s create a background movie sound. Create a New
Layer and name it Background then click to frame 2
and create a Keyframe. Select the banjo2.aif sound
from the Library and drag it onto the stage. Select
frame 2 then go to the Properties panel and look at
the Sync/Repeat options there. You can modify the
effect of a sound or loop it in this panel. Change sync
to stream and repeat to loop then save and test out
your movie. A stream sound has to be reloaded each
time it is repeated but is more reliable in being played
in sync with the movie than an event sound.
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Adding an Interactive Button
Let’s add another button to the Movie so that
the user can stop the movie. Create a new
Layer named Buttons and click to Frame 1.
In the Classic Buttons Common Library, go under the Circle Buttons folder then click the
Stop button and drag it onto the stage.
Make sure that the Stop button is selected thus surrounded in a blue rectangle then go over to the Behavior Panel. The Behavior panel is used to add interactive actions to symbols and objects within Flash. To
add an action, click on the Plus sign then drag down
to Movieclip and over to Goto and Stop. Take the
default options and click on OK. Test out your movie.

See if you can add a Play button to your animation as
well. Test, save and upload your Bulletin Board movie
to the Web. The best part of this movie is that if you
need to change the message then you just double-click
on the msg symbol, make your change and publish again
with Flash— everything else stays the same.
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