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1 Class Examples (Command by Command)

This handout goes over using TeXnicCenter, TeXShop or iTeXMac to cre-
ate a thesis using the isuthesis package. The examples are done here on
a step-by-step basis. So you if get lost, check this sheet. The LATEX sys-
tem and TeXnicCenter front end used here is from the ProTeXt / TexLive
CD-Rom which can be downloaded from www.tug.org. The TeXShop TeX
Mac front end was downloaded from www.uoregon.edu/~koch/texshop/
and the iTeXMac front end also for the Macintosh was downloaded from
itexmac.sourceforge.net. The isuthesis package itself and installation
notes for that package can be found at: http://css.ait.iastate.edu/Tex/.

1.1 Basic Thesis Setup

1. Create a thesis folder. On your desktop, create a folder named Thesis.
This folder will contain all the files related to your thesis.

2. Copy in the thesis template. Open a Web browser and go to the fol-
lowing location: http://css.ait.iastate.edu/Tex/ then click on
the Standard ISUThesis Template link. Right-click (Windows)
or Ctrl-click (Macintosh) each of the template files and copy them to
your Thesis folder that was created in the previous step.

3. Start your LATEX system. Start TeXnicCenter by going under Start
→ Programs→ TeX Applications→ TeXnicCenter. On a Mac-
intosh, simply click on the TeXShop or iTeXMac icon.

4. Open the file- thesis.tex. Pull down under File → Open and select
the file thesis.tex. Take a look and see how this file is organized.
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5. Open the file- titletoc.tex. Pull down under File → Open and select
the file titletoc.tex. This file contains information regarding your
thesis title, your full name and additional area/departmental informa-
tion. Alter this file so that it contains your correct information. Then
close the titletoc.tex file.

6. Compile your thesis using PDFLaTeX. Go back to the thesis.tex doc-
ument. Within TeXnicCenter make sure your Output Profile is set to
LATEX ⇒ PDF, then compile your document by clicking the Build
button. If you are using TeXShop, click on the Typeset button or
within iTeXMac pull down under TeX → Typeset. Note that you
always compile your thesis.tex file. The thesis template uses a Master
file system. The thesis.tex file actually brings in all the other files
when it is compiled. If all went well, a PDF file should have been
created. If an error message pops up, edit the file which contains the
error and then re-compile thesis.tex again with PDFLaTeX.

7. Take a look at the result. Within TeXnicCenter, use the View Output
button to view the current state of your document. Within TeXShop
or iTeXMac, a PDF file should automatically appear. Notice that
your Table of Contents, List of Tables and List of Figures are currently
blank. All of these items in LATEX are always one compilation behind.
So if you make a change that effects one of these thesis areas then you
need to compile your thesis a second time with PDFLaTeX.

8. Compile your thesis.tex file again with PDFLaTeX. Within TeXnic-
Center compile your document by clicking the Build button. If you
are using TeXShop, click on the Typeset button or within iTeXMac
pull down under TeX → Typeset.

9. Take a look at the new results. Your Table of Contents, List of Tables
and List of Figures should now have something in them. For the rest
of this class, we will make changes to one chapter or part of the thesis-
close that part then return to the thesis.tex file to re-compile the thesis
and then after that take a look at the result.

1.2 Spell Checking

On a Windows system to check the spelling in your thesis, go under Start→
Programs → Tex Applications → 4Spell. Use the Select File button
to choose the file to check and then click on the Check Spelling to check
your spelling.
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On a Macintosh system using TeXShop, spelling is automatically checked
for you on the fly. TeXShop underlines in red any word that is not a LATEX
command and that is not in its standard English dictionary. You can also do
a complete spell check by opening a document to check then pulling down
under Edit → Check Spelling.

On a Macintosh system using iTeXMac, you can check your spelling as
you type by pulling down under Edit → Spelling → Check Spelling As
You Type. You can also do a complete spell check by opening a document
to check then pulling down under Edit → Spelling → Spell Checker.

2 A Typical Thesis Done in LATEX

Here are some of the important parts from the standard isuthesis template.
Included here are the front and back portions of the thesis as well as a few
select portions of some of the chapters.

2.1 Thesis.tex

This is the main thesis.tex file. A line that starts with a % is a comment
line. Comment lines which are commands can be uncommented to add or
alter thesis options.

% Template file for a standard thesis
\documentclass[11pt]{report}
\usepackage{isuthesis}
\usepackage[pdftex]{graphicx}
% Standard, old-style thesis
\usepackage{traditional}
\chaptertitle
% Old-style, thesis numbering down to subsubsection
\alternate
% The next line is only used to get a sideways table/figure.
\usepackage{rotating}
% Bibliography without numbers or labels
\usepackage{natbib}
\bibliographystyle{isuapalike}
%\includeonly{titletoc,chapter1}
%Optional Package to add PDF bookmarks and hypertext links
%If used, uncomment phantomsection commands to get LOT/LOF hyperlinks in correct place
%\usepackage[pdftex,hypertexnames=false,linktocpage=true]{hyperref}
%\hypersetup{colorlinks=true,linkcolor=blue,anchorcolor=blue,citecolor=blue,filecolor=blue,urlcolor=blue,bookmarksnumbered=true,pdfview=FitB}
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\begin{document}
\DeclareGraphicsExtensions{.jpg,.pdf,.mps,.png}
\include{titletoc}
% Optional thesis dedication
\include{dedication}
%\pdfbookmark[1]{TABLE OF CONTENTS}{table}
\tableofcontents
\addtocontents{toc}{\def\protect\@chapapp{}}
\cleardoublepage
%\phantomsection
\addcontentsline{toc}{chapter}{LIST OF TABLES}
\listoftables
\cleardoublepage
%\phantomsection
\addcontentsline{toc}{chapter}{LIST OF FIGURES}
\listoffigures
% Comment out the next line if NOT using chaptertitle
\addtocontents{toc}{\def\protect\@chapapp{CHAPTER\ }}
%Optional Acknowledgements
%\include{acknowl}
%Optional thesis abstract
%\include{abstract}
\newpage
\pagenumbering{arabic}
\include{chapter1}
\include{chapter2}
\include{chapter3}
\include{chapter4}
\include{chapter5}
\include{appendix1}
\include{appendix2}
\include{biblio}
\end{document}

2.2 Titletoc.tex

The titletoc.tex file contains title page and related information. You should
update this to contain your thesis title and departmental information. Again
a line that starts with a % is a comment line. Comment lines which are
commands can be uncommented to add or alter thesis options.
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% Template Titlepage File
\title{This is the title of a thesis
submitted to Iowa State University\\
Note that only the first letter of
the first word and proper names
are capitalized}
\author{Wilbur Terrance Johnson}
\degree{MASTER OF SCIENCE}
\major{Human Development and Family Studies}
\level{master’s}
\mprof{Susan D. Ross}
\members{Mary Jones \\ Bjork Petersen}
\notice
% Add these additional lines for a Doctoral Dissertation
%\degree{DOCTOR OF PHILOSOPHY}
%\level{doctoral}
%\format{dissertation}
%\committee{4}
%\members{Mary Jones \\ Bjork Petersen \\ Sam Anders \\ Harold Jones}
% Add these additional lines for a Creative Component
% - also comment out the \maketitle command
%\format{Creative Component}
%\submit{the graduate faculty}
\maketitle

2.3 Chapter1.tex

The chapter1.tex file is the first real chapter of your thesis. It normally
contains an overview of how your thesis fits into the full spectrum of aca-
demic work. All the example shows is how a chapter can be divided into
sections, subsections, subsubsections and beyond. Remember that like a
topic outline, you should always have at least two of a subdivision for that
subdivision to occur.

% Chapter 1 of the Thesis Template File
\chapter{OVERVIEW}

This is the opening paragraph to my thesis which
explains in general terms the concepts and hypothesis
which will be used in my thesis.
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\section{Introduction}

Here initial concepts and conditions are explained and
several hypothesis are mentioned in brief.

\subsection{Hypothesis}

Here one particular hypothesis is explained in depth
and is examined in the light of current literature.

\subsubsection{Parts of the hypothesis}

Here one particular part of the hypothesis that is
currently being explained is examined and particular
elements of that part are given careful scrutiny.

2.4 Chapter2.tex

The chapter2.tex file is normally a “Review of Literature”. The only thing
really interesting in this sample chapter is that the \cite command is used
to cite information that is contained in the bibliography. Just like the Table
of Contents, List of Tables and List of Figures- cited references take an extra
compilation to correctly connect with the bibliography.

By the way, if you change a chapter title make sure that it remains all in
caps. So if you decide to use “Research Review” as your second chapter title
then the command would be \chapter{RESEARCH REVIEW}. The isuthesis
style file does not do this automatically for you.

\chapter{REVIEW OF LITERATURE}

This is the opening paragraph to my thesis which
explains in general terms the concepts and hypothesis
which will be used in my thesis.

\section{Introduction}

Here initial concepts and conditions are explained.
\cite{allen}, \cite{bruner} and \cite{cox}
did the initial work in this area. But in Bruner’s
work~[\cite{bruner}] the definitive model is seen.
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2.5 Chapter3.tex

The chapter3.tex file contains a simple table and a simple figure without
any contents in the table or figure. Table and figures are floating objects in
LATEX which means they can float from page to page until they find enough
room for placement. The standard placement options are tbp for t - top,
b - bottom and p - page. In a thesis, the placement options that you
normally want are h!tb for h - here, t - top and b - bottom. Generally
speaking in a thesis, you want a table or figure to occur right away. The
! option behind the h means that LATEX can cheat the page a little bit to
get the table or figure onto the current page. The \label command that
follows the \isucaption commands allows you to use the \ref command in
your text in order to reference a table or figure without knowing the table
or figure number.

\chapter{METHODS AND PROCEDURES}

This is the opening paragraph to my thesis which
explains in general terms the concepts and hypothesis
which will be used in my thesis.

Here initial concepts and conditions are explained.
As can be seen in Table~\ref{nothing} it is truly
obvious what I am saying is true.

\begin{table}[h!tb] \centering
\isucaption{This table shows a standard empty table}
\label{nothing}

\vspace{ 2 in}
\end{table}

This can also be seen in Figure~\ref{moon} that the
rest is obvious.

\begin{figure}[h!tb] \centering

\vspace{ 2 in}
\isucaption{This table shows a standard empty figure}
\label{moon}
\end{figure}
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2.6 Chapter4.tex

The chapter4.tex file contains a normal table and figure. Normally a tab-
ular environments occurs within a table and the \includegraphics com-
mand occurs within a figure.

The tabular environment makes columns of items in LATEX. At the start
of a tabular environment, you need to specify in braces the number of
columns to create by using the following characters where each character
will hold a space for one column: l - left justified column, c - centered
column, r - right justified column. So for instance {llc} would create
three columns where the first two are left-justified and the last one is cen-
tered. Then within the tabular environment, use a & to go from one column
to the next and then a \\ to specify the end of a row. You can also use the
\hline command to make a horizontal line at the end of a row and add | to
the column identifiers to create vertical lines going down around your table.

The \includegraphics command will take any normal web graphic like
a .jpg, .gif or .png file. The PDFLaTeX compiler cannot handle .ps or .eps
files so you need to convert those or use the epstopdf package to use .ps
and .eps files in a PDFLaTeX thesis.

\chapter{RESULTS}

This is the opening paragraph to my thesis which
explains in general terms the concepts and hypothesis
which will be used in my thesis.

Of course, data on this as seen in Table~\ref{data}
is few and far between.

\begin{table}[h!tb] \centering
\isucaption{Moon Data}
\label{data}
% Use: \begin{tabular{|lcc|} to put table in a box
\begin{tabular}{lcc} \hline
\textbf{Element} & \textbf{Control} & \textbf{Exp.} \\ \hline
Moon Rings & 1.23 & 3.38 \\
Moon Tides & 2.26 & 3.12 \\
Moon Walk & 3.33 & 9.29 \\ \hline
\end{tabular}
\end{table}
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\subsection{Hypothesis}

Here one particular hypothesis is explained in depth
or graphically as seen in Figure~\ref{mgraph}
it is certain that my hypothesis is true.

\begin{figure}[h!tb] \centering

\includegraphics{dc5.jpg}

\isucaption{Durham Centre}
\label{mgraph}
\end{figure}

2.7 Chapter5.tex

The chapter5.tex file contains two more unusual tables / figures that you
might never actually use but that might be very valuable if you actually
need them. This includes a fullpage table which uses the p! placement
option and a sideways table which produces a sideways page for extra wide
tables and figures.

\chapter{SUMMARY AND DISCUSSION}

This is the opening paragraph to my thesis which
explains in general terms the concepts and hypothesis
which will be used in my thesis.

\section{Introduction}

Or graphically as seen in Figure~\ref{mgraph2}
it is certain that my hypothesis is true.

\begin{figure}[p!] \centering

\includegraphics{dc5.jpg}

\isucaption{Durham Centre--- Another View}
\label{mgraph2}
\end{figure}
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\subsection{Hypothesis}

Here one particular hypothesis is explained in depth.
As can be seen in Table~\ref{nothingelse} it is
truly obvious what I am saying is true.

\begin{sidewaystable} \centering
\isucaption{This table shows almost nothing but is a
sideways table and takes up a whole page by itself}
\label{nothingelse}
% Use: \begin{tabular{|lcc|} to put the table in a box
\begin{tabular}{lcc} \hline
\textbf{Element} & \textbf{Control} & \textbf{Exp.} \\ \hline
Moon Rings & 1.23 & 3.38 \\
Moon Tides & 2.26 & 3.12 \\
Moon Walk & 3.33 & 9.29 \\ \hline
\end{tabular}
\end{sidewaystable}

2.8 Bibliography

The biblio.tex file contains a standard Bibliography. The item in brackets
after the \bibitem is what is returned when an item is cited by a cite call
with the label in braces that follows the bracketed item. For instance, if you
use the command \cite{allen} then LATEX would reference the bibitem
with the allen label and return Allen, B. S. (1984).

\renewcommand{\bibname}{\centerline{BIBLIOGRAPHY}}
\unappendixtitle
\interlinepenalty=300
\begin{thebibliography}{99}
\addcontentsline{toc}{chapter}{BIBLIOGRAPHY}

\bibitem[Allen, B.~S.~(1984)]{allen}
Allen, B.~S. (1984). System-assigned learning strategies and CBI.
\emph{Journal of Instructional Computing Research},
\emph{1}(1), 3--18.
\filbreak

\end{thebibliography}
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