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Overview

Many times on social networking sites like a Facebook, MySpace or even a standard blog; you
are given an option to add additional text or links to other sites, graphics and information
using HTML or XHTML. Programs like Dreamweaver or WordPress also use HTML or
XHTML for the creation of Web pages. HTML (Hypertext Markup Language) and XHTML
(Extensible Hypertext Markup Language) are the basic building blocks of the web. This class
goes over the basics of HTML, XHTML and also looks at how one would currently use HTML
on Facebook. No previous HTML background is required but class members are encouraged
to have a Facebook account of their own which they can log in to during class.
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Getting Started

To get started, we are going to learn some basic HTML commands. To do this, we are going
to enter the commands into a standard text editor and then view those commands via a
browser.

2.1

Macintosh

On a Macintosh, double-click the TextEdit application that is normally within the Applications folder. Pull down under File → New. Then enter the following line <b>Hello World</b>
into that file. Next pull down under Format to Make Plain Text.

And finally, pull down under File → Save as and save the file as example1.html.
Double-click example1.html on your desktop to view the file with Safari to see your result.
For the first part of this class, we will make changes to the example1.html file, save the
file and then view the result with Safari by pressing the reload button within Safari. To
re-open with TextEdit and not get forced into Rich Text Format, use the Open option within
TextEdit and turn on the ignore rich text commands option.

2.2

Windows

On a Windows system, open up WordPad by going under All Programs → Accessories
→ WordPad. Enter the following line: <b>Hello World</b> into Wordpad. Pull down
under File → Save As and save the file as example1.html as a Text Document.
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Double-click example1.html on your desktop to view the file with Internet Explorer to
see your result. For the first part of this class, we will make changes to the example1.html
file, save the file and then view the result with Internet Explorer by pressing the reload
button within Internet Explorer.
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HTML Basics

HTML stands for Hypertext Markup Language. It is the markup language used to create
most web pages on the internet. HTML commands known as tags are enclosed in < >
and mostly come in pairs <H1>Topic</H1> which surround the area where the effect is to
take place with a / preceding the ending tag name. For educational purposes and emphasis,
HTML commands are shown within this document in both upper and lowercase but should
all be in lowercase to be XHTML compliant.

3.1

The HTML Page

A full HTML page is made up of various sections.
<HTML>
– marks web page as an HTML file
<HEAD> Title stuff </HEAD>
– marks header of this web page.
<BODY>
<p>Everything else on this page.</p>
</BODY>
– marks body of this web page.
</HTML>
- marks end of an HTML file
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An initial full HTML page might look something like this:

<HTML>
<HEAD>
<TITLE>
Personal Homepage Your Name Here</TITLE>
</HEAD>
<BODY>
<H1>Welcome!</H1>
<P>This is a sample homepage.</P>
<P>Text can be shown in <B>bold</B>
and <EM>emphasis</EM>.</P>
<p>My electronic mail address is
<ADDRESS>somewhere@out.there</ADDRESS></P>
</BODY>
</HTML>

3.2

Titling, Paragraphs and Headings

Titling:
<TITLE>Title of this page</TITLE>
Paragraphs:
This is a line a text. Mark the end of a paragraph with a <P>. Without a <P>
your lines will all run together into one big paragraph.
Technically all paragraphs in HTML should start with a <P> and end with
a </P>. Many HTML documents still only use <P> to mark the end of a
paragraph but many CSS style files and XHTML now require all paragraphs to
be marked with a <P> at the start and a </P> at the end.
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Headings:
Headings are automatically displayed in larger or bolder fonts than normal text.
You can use <H1>Major Topic</H1>, <H2>Submajor Topic</H2> . . . through
<H6>Smallest Subtopic</H6> to divide your page up into sections with multiple H2’s under a single H1 (similar to doing a topic outline).
Headings are used by internet search engines to index your page. So it is important to use Headings where appropriate to get your page indexed correctly.

3.3

Sauces and Pickles for Your Page

Different Types of Text:
<b>Text</b>
—
<em>Text</em> —
<i>Text</i>
—
<tt>Text</tt>
—

creates
creates
creates
creates

bold text
emphasized text
text in italics
fixed width text

Specific Tag Effects:
<br> — creates a line break
<hr> — creates a horizontal line on a page
Specific Tag Types:
<Strong>Text</Strong>
<Address>Ad</Address>
<Pre>t ext</Pre>
<font size=#>Text</font>

—
—
—
—

bold fixed text
e-mail address type text
pre-formatted t ext
# = font size 1-7

Tag Alterations:
<h1–6 Align=ali>Header</h1–6> — Aligned Header
<p Align=ali>Para.</p>
— Aligned Paragraph
<hr Size=#>
— Wide Horizontal Line
(ali=Left, Right or Center
#=number)
Special Characters:
&amp;
&lt;
&gt;
&reg;
&copy;
&nbsp;

—
—
—
—
—
—

creates a &
creates a <
creates a >
Registered Trademark
Creates a c
Creates a printed blank

5

3.4

Lists of Things

An Unnumbered List:
<UL>
<LI> Tennis
<LI> Bowling
</UL>
looks like this:
• Tennis
• Bowling

A Numbered List:
<OL>
<LI> Milk
<LI> Pizza
</OL>
looks like this:
1. Milk
2. Pizza

More List Options:
<ul type=disc|circle|square> . . . </ul>
<ol type=A|a|I|i|1> . . . </ol>
<li type=A|a|I|i|1>

3.5

Images and Links

Images:
You can add a simple graphic GIF, JPG, XBM, PNG or XPM to your web page as follows:
<IMG SRC="filename">
For example, to add the graphic camp.gif to your web page and place it in a centered
area, you would enter:
<center>
<img src="camp.gif">
</center>
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Local Links:
You use links to link one web page to another web page on the internet. Here is an example
of a local textual web link (or anchor) that links from the phrase ‘link to my second page’
to the a second web page name example2.html:
Here is a
<a href="example2.html">
link to my second page</a>.
When a person clicks on the phrase ‘link to my second page’ they will be transported to the
second.html web page. You can try this out yourself by duplicating your example1.html and
creating an example2.html file for yourself.
Global Links:
You could also link from your page (HTML file) to any other page on the internet. To do
this, you need to know the complete URL (Uniform Resource Locator) for that link. For
instance, say I want a link on my page to Yahoo (which has a fine collection of other internet
links). Yahoo’s URL is: http://www.yahoo.com/ so for a link to Yahoo I would enter:
<a href="http://www.yahoo.com/">
A link to Yahoo</a>.
So when I click on ‘A link to Yahoo’, I get transported off to the Yahoo spot on the internet.
Make sure and try this one out for yourself too.
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A Variety of Other HTML items

Centering:
Centering Items on a Page
<center>
...
</center>
Blockquotes:
You can use:
<blockquote>
...
</blockquote>
to make a page look more organized. Blockquote does a double indent which
creates a simple border.
7

Big and Small fonts:
<BIG> creates a large font size which ends with </BIG>.
<SMALL> creates a small font size which ends with </SMALL>.
You can control the font size directly with <FONT SIZE=# > which ends
with </FONT> or <BASEFONT SIZE=#> where # is a number from 1
to 7 (default 3).
Comments:
You can use <!-- Comment. --> to put comments into your HTML file that will
not be displayed by the browser.
Linking to a Specific Point on a Page
A local document anchor can identify a specific web page section, for instance:
<a name=“label”>Section 29</a>
You can then link to that exact section from the same webpage by using:
<a href=“#label”>Link to Section 29.</A>
or you can also add the #label section to the end of a normal hypertext link to
arrive at that exact section.
Note:
While you are using an Internet Browser, under ‘View’ pull down to ‘Source’— to see the
internal html workings of any page on the internet. So find an internet page that you like
and ‘View’ that page to see how it is constructed.
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5.1

HTML Beyond the Basics
Colors

Setting Page Colors
You can alter the <body> tag to set background and link colors:
<body bgcolor=“color” text=“color”
link=“color” vlink=“color” alink=“color”>
where BGCOLOR is background color, TEXT is text color, LINK is link color,
VLINK is visited link color and ALINK is active link color.
A color is in the form #?????? where ?????? is in three ordered pairs of two for
red/green/blue. A single ?? pair can be from 00-FF in value which determines
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the strength of that particular color. 16 Standard Colors (where name can be
used instead of color code):
Black:
#000000
Blue:
#0000FF
Red:
#FF0000
Yellow: #FFFF00
White:
#FFFFFF
Green: #008000
Silver:
#C0C0C0
Gray:
#808080
Lime:
#00FF00
Olive:
#808000
Maroon: #800000
Navy:
#000080
Purple:
#800080
Teal:
#008080
Fuchia:
#FF00FF
Aqua:
#00FFFF
Other Standard Color names:
http://www.w3schools.com/html/html_colornames.asp
Color Chart:
http://www.zspc.com/color/index-e.html
Additional Colors:
Blue Violet:
#9F5F9F
Indian Red:
#4E2F2F
Quartz:
#D9D9F3
Dark Orchid: #9932CD
Light Wood:
#E9C2A6
Orange:
#FF9900
Neon Pink:
#FF6EC7
Orange Red:
#FF2400
Summer Sky: #38B0DE
Yellow Green: #99CC32
Slate Blue:
#007FFF
Forest Green: #238E23
Navy Blue:
#23238E
Dark Purple: #871F78

Cadet Blue:
Goldenrod:
Sea Green:
Plum:
Sienna:
Old Gold:
Feldspar:
Sky Blue:
Turquoise:
Dusty Rose:
Violet:
Pink:
Scarlet:
Copper:

#5F9F9F
#DBDB70
#238E68
#EAADEA
#8E6B23
#CFB53B
#D19275
#3299CC
#ADEAEA
#856363
#4F2F4F
#8C8F8F
#8C1717
#B87333

Changing Text Color
You can control the font color directly with <font size=# color=“color” >
which ends with </font> or <basefont size=#> where # is a number from
1 to 7 (default 3).
Setting a Background Graphic
You can also alter the <body> tag to have HTML use a graphic image for the
background on your webpage:
<body background=“paper.gif ”>
Fuzzy images, small color squares and images with sharp contrasts make for good
backgrounds but can overwhelm your other color choices.
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Linking from a Graphic:
Using a graphic to link two Web pages may sound confusing but it is simply a
combination of a hypertext link and a standard graphic. Here is an example of
a local link from a graphic:
<a href="example2.html">
<img src="quips.gif"></A>
This link is set so that if you click on the ‘quips.gif’ graphic then you will be
transported to the local HTML page named example2.html.
Using this same method you could also link from a graphic to any other page
on the internet. Here is a graphics (quips.gif) link to the bing search engine
(http://www.bing.com/):
<a href="http://www.bing.com/">
<img src="quips.gif"></A>
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HTML Tables

Tables are a good way to organize information on an internet page that is supported by
almost any internet browser.

6.1

Simple Table Example

<table border=5>
<tr>
<td>Stuff in table</td>
<td>More Stuff</td>
</tr>
<tr>
<td>Row 2: Stuff in table</td>
<td>Row 2: More Stuff</td>
</tr>
</table>
<table> - begins a new table
border= defines table border thickness
<tr> - begins a new row
<td> - begins a new entry in a row
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6.2

Table Headers & Captions
The <caption> tag can be used just after the <table> tag to add a caption to
a table.
<table border=2>
<caption><em>Types of Chocolate</em></caption>
<tr><td>Milk</td><td>White</td><td>Dark</td></tr>
</table>
The <th> tag can be used in place of the <td> tag to create a header cell
instead of a data cell. Header cells are normally displayed in bold.
<table border=2>
<caption><em>Types of Chocolate</em></caption>
<tr><th></th><th>Milk</th><th>White</th>
<th>Dark</th></tr>
<tr><th>Amount in Stock</th><td>300</td>
<td>500</td><td>250</td></tr>
</table>

6.3

Table Width
You can specifically define table WIDTH by adding the WIDTH option to the
TABLE tag. WIDTH can be an exact pixel WIDTH or can be more reliable if
expressed as a simple percentage of the total page width.
<table border=2 width=250>
<caption><em>Types of Chocolate</em></caption>
<tr><th></th><th>Milk</th><th>White</th>
<th>Dark</th></tr>
<tr><th>Amount in Stock</th><td>300</td>
<td>500</td><td>250</td></tr>
</table>
<table border=2 width=75%>
<caption><em>Types of Chocolate</em></caption>
<tr><th></th><th>Milk</th><th>White</th>
<th>Dark</th></tr>
<tr><th>Amount in Stock</th><td>300</td>
<td>500</td><td>250</td></tr>
</table>
WIDTH can also be used for data cells with the TD and TH tags.
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6.4

Table Alignment and Spanning
By default, header cells are centered both vertically and horizontally where
data cells are centered vertically and left aligned horizontally. The ALIGN and
VALIGN options allow you to alter this default.
ALIGN= defines row/entry horizontal alignment (CENTER, LEFT or RIGHT)
VALIGN= defines row/entry vertical alignment (TOP, MIDDLE or BOTTOM)
<table border=2 width=75%>
<caption><em>Types of Chocolate</em></caption>
<tr><th></th><th>Milk</th><th>White</th>
<th>Dark</th></tr>
<tr><th>Amount<br> in<br> Stock</th><td>300</td>
<td valign=top>500</td><td align=right>250</td></tr>
</table>
The COLSPAN= option allows a data cell to span more than one table entry.
<table border=3>
<tr align=center>
<td>Stuff in table</td> <td>More Stuff</td>
</tr><tr><td colspan=2>
Row 2: Stuff in table</td></td></table>

6.5

Other Table Options
The CELLSPACING and CELLPADDING table options can be used can be used
to control the width of the borders separating cells and the amount of blank space
within a cell.
<table border=3 cellspacing=9 cellpadding=4>
<tr align=center>
<td>Stuff in table</td> <td>More Stuff</td>
</tr><tr><td colspan=2>
Row 2: Stuff in table</td></td></table>

6.6

Using Tables with Graphics and LInks
Tables can give an organized look to even a complex web page and can be used
to frame a graphic or a hypertext link.
<table border=12><tr>
<td><a href="example2.html">
<img src="drivein.gif"></a></td>
<td><a href="example3.html">
<img src="quips.gif"></a></td>
</tr></table>
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Borderless tables don’t even have to look like a table is really there and can also
be used to create blank space.
<table border=0><tr>
<td><a href="example2.html">
<img src="drivein.gif"></a></td>
<td><a href="example3.html">
<img src="quips.gif"></a></td>
</tr></table>

<table border=0 width=50%><tr>
<td align=right>Hi</td></tr></table>
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Table Example for Facebook
Facebook doesn’t require a full html web page so most of the time you are just
entering table code to create HTML code for Facebook. Note also that the image
files primarily link to images within Facebook. Here is an extended example:
<center>
<imb src="http://sphotos.ak.fbcdn.net/n.jpg">
<table bgcolor="darkseagreen" width=500 border=5>
<tr><td>
<center>
<font size=6>
<b>Camp Cafe</b>
</font>
</center>
<tr><td>
<font size=5>
<i>On Today’s Menu:</i><br>
<center>
<font color="firebrick">Mystery Meat</font><br>
<font color="yellow">Creamed Corn</font><br>
<font color="brown>Hash Browns</font><br>
<font color="darkgreen">Green Beans</font><br>
</center>
</font>
</td>
</tr>
<tr><td>
<font size=5>
<i>Beverage Choices:</i><br>
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<center>
<b><font color="snow">Milk</font></b><br>
<font color="moccasin">Chocolate Milk</font><br>
<font color="blue">Water</font><br>
<font color="brown">Tea</font><br>
<i><font color="red">Bug Juice</font></i><br>
</center>
</font>
</td>
</tr>
<table>
</center>
And it looks like the following on Facebook:
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Adding HTML to Facebook

Facebook and other social media sites such as MySpace and LiveJournal allow you to add
HTML to specific pages or via applications within their social media network. Within
Facebook, the easiest place to add HTML of your own is within a Tab using the application
FBML (Facebook Markup Language) which is a subset of HTML but which includes almost
everything that we have covered so far today. You can also borrow code from an HTML
creation program like Dreamweaver but you often have to remove advanced commands which
are not included in FBML. Due to current Facebook rules, you can only add HTML to Fan
and Business pages so we will have to add one of them to get started.

8.1

Initial Group Setup

Login to Facebook and click on your Profile link in the upper right hand corner. Next
use the search box in the upper left and search for the Buddy Holly fan page or any
fan/business page for that matter.

Once you have found the page, look in the lower left hand corner and you should see a link
that says “Create a Page” or “Create a Page for my business” or “Create a Page Like this
one”. Click on that link to create a new page.
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You need to create a fan page in order to use FBML on Facebook. So fill out the “Offical
Page” information, put in the Page name, click on the “official representative” button and
then click the Create Official Page button.

Your new fan page is created and you should be taken there on Facebook. Now you just
need to add the FBML.

8.2

Adding FBML

To add FBML to a page, go to that page and type in FBML in the search box and go to
the page labeled Static FBML. Click on the Like button and then click on the link on the
left labeled Add to my Page.

16

Click on Add to Page button on the page list provided next to your new fan page then
click on Close:

and return via the Searchbox to your new page.

8.3

Adding your HTML Code

To add HTML to your fan page, click on the Edit Page link on the top left of your page:

Then under the FBML application, click on the Edit link:

You will be taken to an Edit FBML page. On that page, you fill in the Box Title and enter
in your FBML (HTML). Your Box Title will become a Tab Heading for your page and the
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FBML area is where you place your HTML. Enter in Basic HTML and then click on Save
Changes. For now don’t include images/graphics in your code.

When you are finished, you should see on your fan page profile a new tab which links to your
HTML page:
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Adding Graphics:
To add a graphic to your page, you must have first uploaded it to your fan page’s
photo gallery. Go to the Photos tab, click on Create a Photo Album, Name
your album and Upload your photos.
To add an image to your HTML/FBML tab, you will need to get the Image
Address from Facebook. To start with, first go to your photo gallery. On a
Macintosh, Ctrl/Click on the image that you want then pull down to Copy
Image Address.

On a Windows system, Right-Click on the picture then pull down to Properties. Within the Properties area, you will see a full Address (URL) for the
picture. Highlight that address and Right-Click on it then pull down to Copy.

19

After that, go to your main page and click on Edit Page. Next click on Edit
under the Text Area - FBML Application which should take you back to your
Edit FBML page. Insert your image tag and for the src information, do an Edit
→ Paste or a Ctrl/V to stick in the source information. After that, simply
Save your changes.

Next go back to your base page, click on your FBML tab and you should see
your result:
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XHTML or XML
XHTML or XML stands for eXtensible HuperText Markup Language. It is aimed
to replace HTML and is almost identical to HTML 4.01. XHTML is a stricter
and cleaner version of HTML and is defined as an XML (Extensible Markup
Language) application.
Basic Changes to make your HTML compliant with XHTML:
1. All Tag name must be in lowercase so <br> and not <BR>.
2. All Tags tag elements must be closed. So no <p> sitting by itself— instead it must be <p>Paragraph</p>. Or a list element must be <li>list
element</li>
3. Single tag elements like <br> or <hr> must be closed and thus have an
ending tag element </br> or end with a slash <hr />.
4. Attribute values must be in double-quotes so <table width="250"> and
not <table width=250>.
5. The id attribute replaces the name attribute. So use <a id="namedanchor"></a>
and not <a name="namedanchor"></a>.
6. The <!DOCTYPE> attribute is mandatory and must be the first line of your
file. The doctype defines the document type:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
7. You can validate your XHTML code at http://validator.w3.org/
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