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Class Examples (Command by Command)

This handout goes over using TeXWorks (Win/Mac) to create a thesis using
the isuthesis documentclass but you can do the same thing with TeXnicCenter (Windows) or TeXShop (Macintosh) or any other LATEX front end with
only a few minor changes. The examples are done here on a step-by-step
basis. So you if get lost, check this sheet. The LATEX system, TeXnicCenter,
TeXWorks or TeXShop can be downloaded from www.tug.org and more information on their installation can be found at:
http://css.ait.iastate.edu/Tex/installation.html.
The isuthesis documentclass itself and installation notes for that package can be found at: http://css.ait.iastate.edu/Tex/isuthesis.html.
Links to an online video on installing the isuthesis documentclass can be
found at: http://css.ait.iastate.edu/. A full online class involving
“Writing a Thesis with LATEX” which covers most of this document’s material can be found at: www.it.iastate.edu/training/videos/thesis/.

1.1

Basic Thesis Setup

1. Copy in the thesis template. Open a Web browser and go to the following location: http://css.ait.iastate.edu/Tex/isuthesis.html.
Right-click (Windows) or Ctrl-click (Macintosh) the isuthesis Documentclass link and download the zip file to your desktop.
2. Extract the files and move your isuthesiscomplete folder to your desktop. On a Windows system, you will need to extract the files from the
archive to reveal the isuthesiscomplete folder. On a Macintosh system, the files should download to your Downloads folder and extract
themselves, so you should just be able to move the isuthesiscomplete
folder from your Downloads folder to your desktop.
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3. Start your LATEX system. On a Windows system, start TeXWorks by
going under Start → All Programs → MikTeX → TeXWorks.
On a Macintosh, simply click on the TeXShop or TeXWorks icons
which are either on the Dock or in the Applications folder.
4. Open the isuthesiscomplete folder and have a look around. The main
file is called thesis.tex and as long as you keep it at the same folder
level as the isuthesis.cls and isutraditional.sty files then everything
should work properly. The title page, abstract, acknowledgements
and dedication information is contained in the Preface folder. The
chapters of your thesis are contained in the Body folder. While the
references area of your thesis are contained in the Reference folder.
This template by default uses BibTeX for your bibliography.
5. Open the file- thesis.tex. Within TexWorks, pull down under File →
Open and select the file thesis.tex. Take a look and see how this
file is organized. The parts of your thesis are brought into the main
thesis.tex file with \include commands from the various folders in
your installation.
6. Open the file- titlepage.tex. Pull down under File → Open and within
the Preface folder select the file titlepage.tex. This file contains
information regarding your thesis title, your full name and additional
area/departmental information. Alter this file so that it contains your
correct information. Then save and close the titletoc.tex file.
7. Compile your thesis using PDFLaTeX. Go back to the thesis.tex document. Within TeXWorks, make sure your compiler is set to PDFLATEX
then click the Typeset button at the top on the far left. Note that
you always compile your thesis.tex file. The thesis template uses a
Master file system. The thesis.tex file actually brings in all the other
files when it is compiled. If all goes well, a PDF file will have been
created. If an error message pops up, edit the file which contains the
error and then re-compile thesis.tex again with PDFLaTeX.
8. Take a look at the result. A PDF file named thesis.pdf should have been
automatically created for you and then displayed within TeXWorks.
If this didn’t happen, simply double-click the thesis.pdf file on your
desktop within the isuthesiscomplete folder. Notice that your Table
of Contents, List of Tables and List of Figures are currently blank. All
of these type of items in LATEX are always one compilation behind. So
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if you make a change that effects one of these thesis areas then you
need to compile your thesis a second time with PDFLaTeX.
9. Compile your thesis.tex file again with PDFLaTeX. Typeset your thesis.tex document again within TeXWorks. A new thesis.pdf file should
appear.
10. Take a look at the new results. Your Table of Contents, List of Tables
and List of Figures should now have something in them. For the rest
of this class, we will make changes to one chapter or part of the thesisclose that part then return to the thesis.tex file to re-compile the thesis
and then after that take a look at the result.
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Spell Checking

Within TeXWorks on a Windows system, pull down under Edit → Spelling
→ en US to have your spelling checked as you type. To check your spelling
wiithin TeXWorks on a Mactinosh system, pull down under Edit → Spelling
but by default no standard dictionary is installed. To install a standard dictionary for the Macintosh version of TeXWorks go to:
http://code.google.com/p/texworks/wiki/SpellingDictionaries and
follow the installation directions there.
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A Typical Thesis Done in LATEX

Here are some of the important parts from the standard isuthesis documentclass template. Included here are the front and back portions of the thesis
as well as a few select portions of some of the other chapters.

3.1

Thesis.tex

This is the main thesis.tex file. A line that starts with a % is a comment
line. Comment lines which are commands can be uncommented to add or
alter thesis options.
\documentclass[11pt]{isuthesis}
\usepackage[pdftex]{graphicx}
\usepackage{isutraditional}
\chaptertitle
% Old-style, thesis numbering down to subsubsection
\alternate
\usepackage{rotating}
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% Bibliography without numbers or labels
\usepackage{natbib}
\bibliographystyle{apa}
%\includeonly{titletoc,chapter1}
%Optional Package to add PDF bookmarks and hypertext links
\usepackage[pdftex,hypertexnames=false,linktocpage=true]{hyperref}
\hypersetup{colorlinks=true,linkcolor=blue,anchorcolor=blue,citecolor=blue,filecolor=
\begin{document}
\DeclareGraphicsExtensions{.jpg,.pdf,.mps,.png}
\include{Preface/titlepage}
% Optional thesis dedication
\include{Preface/dedication}
% Table of Contents, List of Tables and List of Figures
\pdfbookmark[1]{TABLE OF CONTENTS}{table}
\tableofcontents
\addtocontents{toc}{\def\protect\@chapapp{}} \cleardoublepage \phantomsection
\addcontentsline{toc}{chapter}{LIST OF TABLES}
\listoftables
\cleardoublepage \phantomsection \addcontentsline{toc}{chapter}{LIST OF FIGURES}
\listoffigures
% Comment out the next line if NOT using chaptertitle
\addtocontents{toc}{\def\protect\@chapapp{CHAPTER\ }}
%Optional Acknowledgements
\cleardoublepage \phantomsection
\include{Preface/acknowl}
%Optional thesis abstract
\cleardoublepage \phantomsection
\include{Preface/abstract}
\newpage
\pagenumbering{arabic}
\include{Body/chapter1}
\include{Body/chapter2}
\include{Body/chapter3}
\include{Body/chapter4}
\include{Body/chapter5}
\include{Appendix/appendix1}
\include{Appendix/appendix2}
\include{Reference/bibtex}
%\include{Reference/biblio}
\end{document}
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3.2

Titlepage.tex

The titlepage.tex file contains title page and related information. You
should update this to contain your thesis title and departmental information.
Again a line that starts with a % is a comment line. Comment lines which
are commands can be uncommented to add or alter thesis options.
% Template Titlepage File
\title{This is the title of a thesis
submitted to Iowa State University\\
Note that only the first letter of
the first word and proper names
are capitalized}
\author{Wilbur Terrance Johnson}
\degree{MASTER OF SCIENCE}
\major{Human Development and Family Studies (Marriage and Family Therapy)}
\level{master’s}
\mprof{Susan D. Ross}
\members{Mary Jones \\ Bjork Petersen}
\notice
% Add these additional lines for a Doctoral Dissertation
%\degree{DOCTOR OF PHILOSOPHY}
%\level{doctoral}
%\format{dissertation}
%\committee{4}
%\members{Mary Jones \\ Bjork Petersen \\ Sam Anders \\ Harold Jones}
% Add these additional lines for a Creative Component
% - also comment out the \maketitle command
%\format{Creative Component}
%\submit{the graduate faculty}
\maketitle

3.3

Chapter1.tex

The chapter1.tex file is the first real chapter of your thesis. It normally
contains an overview of how your thesis fits into the full spectrum of academic work. All the example shows is how a chapter can be divided into
sections, subsections, subsubsections and beyond. Remember that like a
topic outline, you should always have at least two of a subdivision for that
subdivision to occur.
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% Chapter 1 of the Thesis Template File
\chapter{OVERVIEW}
This is the opening paragraph to my thesis which
explains in general terms the concepts and hypothesis
which will be used in my thesis.
With more general information given here than really
necessary.
\section{Introduction}
Here initial concepts and conditions are explained and
several hypothesis are mentioned in brief.
\subsection{Hypothesis}
Here one particular hypothesis is explained in depth
and is examined in the light of current literature.
\subsubsection{Parts of the hypothesis}
Here one particular part of the hypothesis that is
currently being explained is examined and particular
elements of that part are given careful scrutiny.

3.4

Chapter2.tex

The chapter2.tex file is normally a “Review of Literature”. The only
thing really interesting in this sample chapter is that the \cite command
is used to cite information that is contained in the bibliography. Just like
the Table of Contents, List of Tables and List of Figures- cited references
take something extra to correctly connect with the bibliography which we
discuss later on in the Bibliographic area.
By the way, if you change a chapter title— try and make sure that it
remains all in caps. So if you decide to use “Research Review” as your second
chapter title then the command would be \chapter{RESEARCH REVIEW}.
The isuthesis documentclass does not do this automatically for you.
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\chapter{REVIEW OF LITERATURE}
This is the opening paragraph to my thesis which
explains in general terms the concepts and hypothesis
which will be used in my thesis.
With more general information given here than really
necessary.
\section{Introduction}
Here initial concepts and conditions are explained and
several hypothesis are mentioned in brief.
\cite{allen}, \cite{bruner} and \cite{cox}
did the initial work in this area. But in Struss’ work~[\cite{struss}]
the definitive model is seen.

3.5

Chapter3.tex

The chapter3.tex file contains a simple table and a simple figure without
any contents in the table or figure. Table and figures are floating objects in
LATEX which means they can float from page to page until they find enough
room for placement. The standard placement options are tbp for t - top,
b - bottom and p - page. In a thesis, the placement options that you
normally want are h!tb for h - here, t - top and b - bottom. Generally
speaking in a thesis, you want a table or figure to occur right away. The !
option behind the h means that LATEX can cheat the page a little bit to get
the table or figure onto the current page.
The \label command that follows the \isucaption commands allows
you to use the \ref command in your text in order to reference a table or
figure without knowing the table or figure number.

\chapter{METHODS AND PROCEDURES}
This is the opening paragraph to my thesis which
explains in general terms the concepts and hypothesis
which will be used in my thesis.
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With more general information given here than really
necessary.
\section{Introduction}
Here initial concepts and conditions are explained and
several hypothesis are mentioned in brief.
As can be seen in Table~\ref{nothing} it is truly
obvious what I am saying is true.
\begin{table}[h!tb] \centering
\isucaption{This table shows a standard empty table}
\label{nothing}
\vspace{ 2 in}
\end{table}
\subsection{Hypothesis}
Here one particular hypothesis is explained in depth
and is examined in the light of current literature.
This can also be seen in Figure~\ref{moon} that the
rest is obvious.
\begin{figure}[h!tb] \centering
\vspace{ 2 in}
\isucaption{This table shows a standard empty figure}
\label{moon}
\end{figure}

3.6

Chapter4.tex

The chapter4.tex file contains a normal table and figure. Normally a tabular environments occurs within a table and the \includegraphics command occurs within a figure.
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The tabular environment makes columns of items in LATEX. At the start
of a tabular environment, you need to specify in braces the number of
columns to create by using the following characters where each character
will hold a space for one column: l - left justified column, c - centered
column, r - right justified column. So for instance {llc} would create
three columns where the first two are left-justified and the last one is centered. Then within the tabular environment, use a & to go from one column
to the next and then a \\ to specify the end of a row. You can also use the
\hline command to make a horizontal line at the end of a row and add | to
the column identifiers to create vertical lines going down around your table.
The \includegraphics command will take any normal web graphic like
a .jpg, .pdf or .png file. The PDFLaTeX compiler cannot handle .ps or .eps
files so you need to convert those or use the epstopdf package to use .ps
and .eps files in a PDFLaTeX thesis.

\chapter{RESULTS}
This is the opening paragraph to my thesis which
explains in general terms the concepts and hypothesis
which will be used in my thesis.
With more general information given here than really
necessary.
\section{Introduction}
Here initial concepts and conditions are explained and
several hypothesis are mentioned in brief.
Of course, data on this as seen in Table~\ref{data}
is few and far between.
\begin{table}[h!tb] \centering
\isucaption{Moon Data}
\label{data}
% Use: \begin{tabular{|lcc|} to put table in a box
\begin{tabular}{lcc} \hline
\textbf{Element} & \textbf{Control} & \textbf{Experimental} \\ \hline
Moon Rings & 1.23 & 3.38 \\
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Moon Tides & 2.26 & 3.12 \\
Moon Walk & 3.33 & 9.29 \\ \hline
\end{tabular}
\end{table}
\subsection{Hypothesis}
Here one particular hypothesis is explained in depth
and is examined in the light of current literature.
Or graphically as seen in Figure~\ref{mgraph}
it is certain that my hypothesis is true.
\begin{figure}[h!tb] \centering
\includegraphics{Images/dc5}
\isucaption{Durham Centre}
\label{mgraph}
\end{figure}

3.7

Chapter5.tex

The chapter5.tex file contains two more unusual tables / figures that you
might never actually use but that also might be very valuable if you actually
need them. This includes a fullpage table which uses the p! placement
option and a sideways table which produces a sideways page for extra wide
tables and figures.
\chapter{SUMMARY AND DISCUSSION}
This is the opening paragraph to my thesis which
explains in general terms the concepts and hypothesis
which will be used in my thesis.
With more general information given here than really
necessary.
\section{Introduction}
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Here initial concepts and conditions are explained and
several hypothesis are mentioned in brief.
Or graphically as seen in Figure~\ref{mgraph2}
it is certain that my hypothesis is true.
\begin{figure}[p!] \centering
\includegraphics{Images/dc5}
\isucaption{Durham Centre--\label{mgraph2}
\end{figure}

Another View}

\subsection{Hypothesis}
Here one particular hypothesis is explained in depth
and is examined in the light of current literature.
As can be seen in Table~\ref{nothingelse} it is
truly obvious what I am saying is true.
\begin{sidewaystable} \centering
\isucaption{This table shows almost
sideways table and takes up a whole
\label{nothingelse}
% Use: \begin{tabular{|lcc|} to put
\begin{tabular}{lcc} \hline
\textbf{Element} & \textbf{Control}
Moon Rings & 1.23 & 3.38 \\
Moon Tides & 2.26 & 3.12 \\
Moon Walk & 3.33 & 9.29 \\ \hline
\end{tabular}
\end{sidewaystable}
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nothing but is a
page by itself}
table in a box
& \textbf{Experimental} \\ \hline

3.8
3.8.1

Bibliography
Bibtex.tex

The standard isuthesis template uses a Bibtex bibliography. The file is
named bibtex.tex but the contents of the files are very simple:
\renewcommand{\bibname}{\centerline{BIBLIOGRAPHY}}
\unappendixtitle
\newpage
\phantomsection
\addcontentsline{toc}{chapter}{BIBLIOGRAPHY}
\bibliography{Reference/mybib}
The \bibliography{Reference/mybib} refers to the file mybib.bib which
is your Bibtex bibliography. An earlier line in the thesis.tex file \thebibliography{apa}
informs Bibtex as to what sort of bibliography to produce. Bibtex looks at
all the \cite commands in your thesis and produces the type of bibliography
specified using the citations that were cited.
To produce a bibliography with Bibtex, one must use the Bibtex compiler
on your main thesis.tex file (which may initially produce an error message)
then Bibtex your reference file mybib.bib. After all that simply go back and
PDFLATEX your main thesis.tex file twice. You have to do this procedure any
time that you update your references. It sounds like a lot of work but Bibtex
also does a lot of work for you in creating a well-formatted bibliography.
The mybib.bib file needs to contains references for all cited material.
People who use LATEX tend to create one mybib.bib file that they use all the
time as Bibtex only uses the cited material within any paper or dissertation
to create the Bibliography.
Here is what the mybib.bib file actually looks like:
@mastersthesis{struss,
AUTHOR = "Joseph A. Struss",
TITLE = "An investigation of the sequence of utilizing a
simulation in an introductory programming course",
SCHOOL = "Iowa State University",
YEAR = 1996}
@book{bruner,
AUTHOR = "J. Bruner",
Title = "The process of education",
PUBLISHER = {Random House},
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ADDRESS = {New York},
YEAR = 1960}
More information on the format of the .bib file can be found on Wikipedia:
http://en.wikipedia.org/wiki/BibTeX. But it is not an overly difficult
format to figure out.
You can find many .bib entires for Bibtex bibliographic citations on
Google. For more information on this, go to:
http://amath.colorado.edu/documentation/LaTeX/reference/faq/bibstyles.html
Many people also use Endnote bibliographic software package to create
their bibliography. For information on using Endnote with LATEX go to:
http://www.rhizobia.co.nz/latex/convert.html
3.8.2

Biblio.tex

If you wish to use thebibliography environment instead on Bibtex, just
changed the last include of your thesis to \include{Reference/biblio}.
The biblio.tex file contains a standard old-style LATEX Bibliography. The
item in brackets after the \bibitem is what is returned when an item is cited
by a cite call with the label in braces that follows the bracketed item. For
instance, if you use the command \cite{allen} then LATEX would reference
the bibitem with the allen label and return Allen, B. S. (1984).

\renewcommand{\bibname}{\centerline{BIBLIOGRAPHY}}
\unappendixtitle
\interlinepenalty=300
% For no page break use thebibnopage environment
\begin{thebibliography}{99}
\addcontentsline{toc}{chapter}{BIBLIOGRAPHY}
\bibitem[Allen, B.~S.~(1984)]{allen}
Allen, B.~S. (1984). System-assigned learning strategies and CBI.
\emph{Journal of Instructional Computing Research},
\emph{1}(1), 3--18.
\filbreak
\end{thebibliography}
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More Information

The complete isuthesis documentclass manual is available at:
http://css.ait.iastate.edu/Tex/Tex/isuthesis.pdf
for more specific thesis information.
An online instructional video for the isuthesis documentclass is also available from: http://css.ait.iastate.edu/.
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